summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index d092a22..66a14c3 100644
--- a/default.nix
+++ b/default.nix
@@ -7,6 +7,7 @@
, postgresql
, postgresqlTestHook
, python3
+, zlib
}:
rustPlatform.buildRustPackage rec {
@@ -21,6 +22,7 @@ rustPlatform.buildRustPackage rec {
];
buildInputs = [
openssl
+ zlib
];
postPatch = ''
@@ -47,4 +49,5 @@ rustPlatform.buildRustPackage rec {
ROCKET_VAPID_KEY = "private_key.pem";
ROCKET_VAPID_SUBJECT = "undefined"; # not needed for tests
ROCKET_MAIL_FROM = "minor skulk <noreply@localhost>";
+ ROCKET_LOG_LEVEL = "debug";
}