summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2023-02-04 01:00:45 +0100
committerpennae <github@quasiparticle.net>2023-02-04 02:42:13 +0100
commit75f9eae5ddb80ccb25b64237f7ceb4bea79e3c98 (patch)
tree8420c00afc226b6c01ebff51541de0396cb2b375 /default.nix
parent8fc5f18c71bed12414cade0cd9c980faef31cff5 (diff)
downloadminor-skulk-75f9eae5ddb80ccb25b64237f7ceb4bea79e3c98.tar.gz
minor-skulk-75f9eae5ddb80ccb25b64237f7ceb4bea79e3c98.tar.xz
minor-skulk-75f9eae5ddb80ccb25b64237f7ceb4bea79e3c98.zip
update dependencies
a few were vulnerable according to cargo-audit, but none of it would've mattered for us (probably). time is still vulnerable, but that really doesn't matter.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index d092a22..66a14c3 100644
--- a/default.nix
+++ b/default.nix
@@ -7,6 +7,7 @@
, postgresql
, postgresqlTestHook
, python3
+, zlib
}:
rustPlatform.buildRustPackage rec {
@@ -21,6 +22,7 @@ rustPlatform.buildRustPackage rec {
];
buildInputs = [
openssl
+ zlib
];
postPatch = ''
@@ -47,4 +49,5 @@ rustPlatform.buildRustPackage rec {
ROCKET_VAPID_KEY = "private_key.pem";
ROCKET_VAPID_SUBJECT = "undefined"; # not needed for tests
ROCKET_MAIL_FROM = "minor skulk <noreply@localhost>";
+ ROCKET_LOG_LEVEL = "debug";
}