summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 1942086..f97d645 100644
--- a/default.nix
+++ b/default.nix
@@ -32,9 +32,6 @@ rustPlatform.buildRustPackage rec {
patchShebangs ./tests/run.sh
'';
- # tests can't run multithreaded yet
- dontUseCargoParallelTests = true;
-
# test config for postgres hook and integration tests
PGDATABASE = "testdb";
PGUSER = "testuser";
@@ -44,7 +41,6 @@ rustPlatform.buildRustPackage rec {
ROCKET_VAPID_KEY = "private_key.pem";
ROCKET_VAPID_SUBJECT = "undefined"; # not needed for tests
ROCKET_MAIL_FROM = "minor skulk <noreply@localhost>";
- ROCKET_MAIL_PORT = 2525;
preCheck = ''
openssl ecparam -genkey -name prime256v1 -out private_key.pem