summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-07-14 09:17:16 +0200
committerpennae <github@quasiparticle.net>2022-07-14 09:17:16 +0200
commit062cd0ff0176f1f9924e3ae89c0eaf01a8d6fd04 (patch)
treec9d0409c5ec2aa60edad4ee590b746cb645208e7 /default.nix
parent566d6ccee21fc52943cf1862222f2e9a8927403c (diff)
downloadminor-skulk-062cd0ff0176f1f9924e3ae89c0eaf01a8d6fd04.tar.gz
minor-skulk-062cd0ff0176f1f9924e3ae89c0eaf01a8d6fd04.tar.xz
minor-skulk-062cd0ff0176f1f9924e3ae89c0eaf01a8d6fd04.zip
allow integration tests to run in parallel
this doesn't do much for performance, but it does allow running the tests with a simple `cargo t`.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix4
1 files changed, 0 insertions, 4 deletions
diff --git a/default.nix b/default.nix
index 1942086..f97d645 100644
--- a/default.nix
+++ b/default.nix
@@ -32,9 +32,6 @@ rustPlatform.buildRustPackage rec {
patchShebangs ./tests/run.sh
'';
- # tests can't run multithreaded yet
- dontUseCargoParallelTests = true;
-
# test config for postgres hook and integration tests
PGDATABASE = "testdb";
PGUSER = "testuser";
@@ -44,7 +41,6 @@ rustPlatform.buildRustPackage rec {
ROCKET_VAPID_KEY = "private_key.pem";
ROCKET_VAPID_SUBJECT = "undefined"; # not needed for tests
ROCKET_MAIL_FROM = "minor skulk <noreply@localhost>";
- ROCKET_MAIL_PORT = 2525;
preCheck = ''
openssl ecparam -genkey -name prime256v1 -out private_key.pem