summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3355184..246e51c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,13 +28,18 @@ subtle = "2.4.1"
time = { version = "0.3.11", features = [ "serde" ] }
url = "2.2.2"
validator = { version = "0.15", features = [ "derive" ] }
-web-push = "0.9.2"
[dependencies.lettre]
version = "0.10"
default-features = false
features = [ "smtp-transport", "hostname", "builder", "tokio1-native-tls", "serde" ]
+# default client (isahc) uses libnghttp2-sys which stopped building in nix
+[dependencies.web-push]
+version = "0.9.2"
+default-features = false
+features = ["hyper-client"]
+
[dev-dependencies]
hex-literal = "0.3.4"