summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2023-02-04 02:16:02 +0100
committerpennae <github@quasiparticle.net>2023-02-04 02:31:51 +0100
commit65bfd803eb943078cf3608003039708c06f58454 (patch)
tree4dbdbef0fe1b4e596fa98307c7b5086e3c109f25 /Cargo.toml
parentf2b7857f530c7c33a3157e1235a382424b919df7 (diff)
downloadminor-skulk-65bfd803eb943078cf3608003039708c06f58454.tar.gz
minor-skulk-65bfd803eb943078cf3608003039708c06f58454.tar.xz
minor-skulk-65bfd803eb943078cf3608003039708c06f58454.zip
switch to hyper backend for web-push
upgrading dependencies will mean we have to use hyper for web-push instead of isahc. sadly hyper doesn't send content-length headers for empty bodies, but we can fudge that for the tests.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3355184..246e51c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,13 +28,18 @@ subtle = "2.4.1"
time = { version = "0.3.11", features = [ "serde" ] }
url = "2.2.2"
validator = { version = "0.15", features = [ "derive" ] }
-web-push = "0.9.2"
[dependencies.lettre]
version = "0.10"
default-features = false
features = [ "smtp-transport", "hostname", "builder", "tokio1-native-tls", "serde" ]
+# default client (isahc) uses libnghttp2-sys which stopped building in nix
+[dependencies.web-push]
+version = "0.9.2"
+default-features = false
+features = ["hyper-client"]
+
[dev-dependencies]
hex-literal = "0.3.4"