summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-07-25 02:26:35 +0200
committerpennae <github@quasiparticle.net>2022-07-25 02:45:55 +0200
commit9e6572fa282a18fecfb31a2c35c17c0e8c23e371 (patch)
treec4ead0f54601fe010e2e17b0a8b43f6362b1c1a4 /Cargo.toml
parent9aacaaf079373f8bc25f0533d7f6218e691c5de7 (diff)
downloadminor-skulk-9e6572fa282a18fecfb31a2c35c17c0e8c23e371.tar.gz
minor-skulk-9e6572fa282a18fecfb31a2c35c17c0e8c23e371.tar.xz
minor-skulk-9e6572fa282a18fecfb31a2c35c17c0e8c23e371.zip
remove dependency on chrono
prompted by a cargo audit run. time works just as well and is better maintained. web-push still uses chrono, but from the looks of things it won't be affected.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9a67b16..239e1a0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,7 +8,6 @@ edition = "2021"
[dependencies]
anyhow = "1.0"
base64 = "0.13"
-chrono = "0.4.19"
dotenv = "0.15"
either = "1.7"
futures = "0.3.21"
@@ -25,8 +24,9 @@ scrypt = { version = "0.10", features = [ "simple" ] }
serde = { version = "1.0", features = [ "derive" ] }
serde_json = "1.0"
sha2 = "0.10.2"
-sqlx = { version = "0.6.0", features = [ "runtime-tokio-native-tls", "postgres", "chrono", "json", "offline" ] }
+sqlx = { version = "0.6.0", features = [ "runtime-tokio-native-tls", "postgres", "time", "json", "offline" ] }
subtle = "2.4.1"
+time = { version = "0.3.11", features = [ "serde" ] }
url = "2.2.2"
validator = { version = "0.15", features = [ "derive" ] }
web-push = "0.9.2"