summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/default.nix b/default.nix
index f97d645..d092a22 100644
--- a/default.nix
+++ b/default.nix
@@ -14,16 +14,11 @@ rustPlatform.buildRustPackage rec {
version = "0.1.0";
src = lib.cleanSource ./.;
+ cargoLock.lockFile = ./Cargo.lock;
nativeBuildInputs = [
pkg-config
];
- checkInputs = [
- openssl
- postgresql
- postgresqlTestHook
- (python3.withPackages (p: [ p.pytest p.pyfxa p.requests p.http-ece p.aiosmtpd ]))
- ];
buildInputs = [
openssl
];
@@ -32,6 +27,17 @@ rustPlatform.buildRustPackage rec {
patchShebangs ./tests/run.sh
'';
+ nativeCheckInputs = [
+ openssl
+ postgresql
+ postgresqlTestHook
+ (python3.withPackages (p: [ p.pytest p.pyfxa p.requests p.http-ece p.aiosmtpd ]))
+ ];
+
+ preCheck = ''
+ openssl ecparam -genkey -name prime256v1 -out private_key.pem
+ '';
+
# test config for postgres hook and integration tests
PGDATABASE = "testdb";
PGUSER = "testuser";
@@ -41,10 +47,4 @@ rustPlatform.buildRustPackage rec {
ROCKET_VAPID_KEY = "private_key.pem";
ROCKET_VAPID_SUBJECT = "undefined"; # not needed for tests
ROCKET_MAIL_FROM = "minor skulk <noreply@localhost>";
-
- preCheck = ''
- openssl ecparam -genkey -name prime256v1 -out private_key.pem
- '';
-
- cargoLock.lockFile = ./Cargo.lock;
}