summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-07-13 10:33:30 +0200
committerpennae <github@quasiparticle.net>2022-07-13 13:27:12 +0200
commit2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328 (patch)
treecaff55807c5fc773a36aa773cfde9cd6ebbbb6c8 /flake.nix
downloadminor-skulk-2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328.tar.gz
minor-skulk-2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328.tar.xz
minor-skulk-2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328.zip
initial import
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..8276544
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,32 @@
+{
+ inputs = {
+ nixpkgs.url = github:NixOS/nixpkgs/nixos-unstable-small;
+ };
+
+ outputs = { self, nixpkgs }:
+ let
+ systems = { "x86_64-linux" = {}; };
+ combine = fn: with builtins;
+ let
+ parts = mapAttrs (s: _: fn (nixpkgs.legacyPackages.${s})) systems;
+ keys = foldl' (a: b: a // b) {} (attrValues parts);
+ in
+ mapAttrs (k: _: mapAttrs (s: _: parts.${s}.${k} or {}) systems) keys;
+ in
+ combine (pkgs: rec {
+ packages = rec {
+ minor-skulk = pkgs.callPackage ./default.nix {};
+ default = minor-skulk;
+ };
+
+ devShells.default = pkgs.mkShell {
+ inputsFrom = [ packages.default ];
+ packages = with pkgs; [
+ rustfmt
+ rust-analyzer
+ clippy
+ sqlx-cli
+ ];
+ };
+ });
+}