summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-07-13 10:33:30 +0200
committerpennae <github@quasiparticle.net>2022-07-13 13:27:12 +0200
commit2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328 (patch)
treecaff55807c5fc773a36aa773cfde9cd6ebbbb6c8 /Cargo.toml
downloadminor-skulk-2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328.tar.gz
minor-skulk-2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328.tar.xz
minor-skulk-2f8dce44d3f2be74b5c6ec0a2e7f4ceced715328.zip
initial import
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml41
1 files changed, 41 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..da84734
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,41 @@
+[package]
+name = "minor-skulk"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0"
+base64 = "0.13"
+chrono = "0.4.19"
+dotenv = "0.15"
+either = "1.7"
+futures = "0.3.21"
+hawk = "4.0.0"
+hex = "0.4"
+hkdf = "0.12.3"
+hmac = "0.12.1"
+humantime-serde = "1.1.1"
+lazy_static = "1.4"
+lettre = { version = "0.10", features = [ "tokio1", "tokio1-native-tls", "serde" ] }
+password-hash = "0.4"
+rand = "0.8.5"
+rocket = { version = "0.5.0-rc.2", features = [ "json" ] }
+scrypt = { version = "0.10", features = [ "simple" ] }
+serde = { version = "1.0", features = [ "derive" ] }
+serde_json = "1.0"
+sha2 = "0.10.2"
+sqlx = { version = "0.6.0", features = [ "runtime-tokio-native-tls", "postgres", "chrono", "json", "offline" ] }
+subtle = "2.4.1"
+url = "2.2.2"
+validator = { version = "0.15", features = [ "derive" ] }
+web-push = "0.9.2"
+zeroize = { version = "1.4.3", features = [ "zeroize_derive" ] }
+
+[dev-dependencies]
+hex-literal = "0.3.4"
+
+[profile.dev.package.scrypt]
+# avoid tests taking a huge amount of time due to unoptimized scrypt
+opt-level = 2