summaryrefslogtreecommitdiff
path: root/test/simple/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'test/simple/secrets.nix')
-rw-r--r--test/simple/secrets.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/test/simple/secrets.nix b/test/simple/secrets.nix
new file mode 100644
index 0000000..31abf74
--- /dev/null
+++ b/test/simple/secrets.nix
@@ -0,0 +1,10 @@
+rec {
+ users.user = "age16w4643wxn796n26ev9dus5a8v3zfzj74uf0vr7cakdpfaz6j2vasvjqvwg";
+ hosts.main = "age1kpyxel2fy7y52rc6n32zwy99gpaersn62f8uejj62vmmymnutdvqx5t258";
+ hosts.aux = "age1xjtclyph0jfcu0pdmxnmz4yj04hjared5ue4u385whqpl79f2ydqng0x0l";
+ default = [ users.user hosts.main ];
+ secrets = {
+ root = [ hosts.aux ];
+ "user/sec" = [ hosts.aux ];
+ };
+}