summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorpennae <github@quasiparticle.net>2022-05-28 15:14:52 +0200
committerpennae <github@quasiparticle.net>2022-06-01 01:45:18 +0200
commit50068653801991e67487f1b555b83f9232a3bd48 (patch)
tree229f7427e4cadbe3e9fbdee3c07a622fa59fb54b /Cargo.toml
downloadlabel-tracker-50068653801991e67487f1b555b83f9232a3bd48.tar.gz
label-tracker-50068653801991e67487f1b555b83f9232a3bd48.tar.xz
label-tracker-50068653801991e67487f1b555b83f9232a3bd48.zip
initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..f96e157
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "label-tracker"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+anyhow = "1.0"
+chrono = { version = "0.4.19", features = [ "serde" ] }
+clap = { version = "3.1.18", features = [ "derive" ] }
+graphql_client = { version = "0.10", features = [ "reqwest-blocking" ] }
+log = "0.4"
+pretty_env_logger = "0.4"
+reqwest = { version = "0.11.10", features = [ "json", "blocking" ] }
+rss = "2.0.1"
+serde = "1.0"
+serde_json = "1.0.81"
+tempfile = "3.3.0"