summaryrefslogtreecommitdiff
path: root/openwrt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'openwrt/default.nix')
-rw-r--r--openwrt/default.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/openwrt/default.nix b/openwrt/default.nix
index 4bd00fb..d609760 100644
--- a/openwrt/default.nix
+++ b/openwrt/default.nix
@@ -174,10 +174,7 @@ let
# apply the new config and wait for the box to go down via ssh connection
# timeout.
log 'applying config'
- ssh '
- export LOG_FMT="'"$CYAN"'>> %s'"$NORMAL"'"
- /etc/init.d/config_generation apply </dev/null 2>&1 \
- | logger -t '"$TAG" &
+ ssh '/etc/init.d/config_generation apply </dev/null 2>&1 | logger -t '"$TAG" &
ssh 'logread -l9999 -f' | awk -v FS="$TAG: " '$2 { print $2 }' || true
log 'waiting for device to return'